Arduino & Co dans le moteur ?

Page 3 sur 4 Précédent  1, 2, 3, 4  Suivant

Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  tboll le Jeu 30 Juil 2020 - 0:00

Bonsoir Julien, bonsoir à tous,

Effectivement, la 845 peut démarrer à froid mais ça ne peut pas lui faire de mal une petite préchauffe.

Il faudrait quand même savoir s'il existe une logique à cette séquence de préchauffe pour pouvoir établir une règle générale pour tout type d'appareils à tubes et quelque soient les tubes. Par exemple, j'ai l'espoir de remettre en route à l'occasion des 300B avant des les mettre à la casse...

Il faut peut être tenir compte de la tension de chauffage des filaments ou l'ampérage ou la surface de la cathode.

Dernière solution j'en... (quiquine) les mouches pour rien.

Thierry


_________________
- VOT-HP et 416-8B GPA Altec Lansing Alnico
- Pavillon Iwata 1 pouce et compression ALTEC 909-8A
- Tweeter Fostex T925
- CD Marantz 6002
- préamplificateur 76/6SN7 (Sound Practices)
- SE 845 en phase de tests et d'essais
tboll
tboll
Membre Bleu
Membre Bleu

Messages : 422
Date d'inscription : 01/03/2019
Localisation : Chartreuse

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  Pierrick le Jeu 30 Juil 2020 - 17:30

tboll a écrit:Bonsoir Julien, bonsoir à tous,

Effectivement, la 845 peut démarrer à froid mais ça ne peut pas lui faire de mal une petite préchauffe.

Il faudrait quand même savoir s'il existe une logique à cette séquence de préchauffe pour pouvoir établir une règle générale pour tout type d'appareils à tubes et quelque soient les tubes. Par exemple, j'ai l'espoir de remettre en route à l'occasion des 300B avant des les mettre à la casse...

Il faut peut être tenir compte de la tension de chauffage des filaments ou l'ampérage ou la surface de la cathode.

Dernière solution j'en... (quiquine) les mouches pour rien.

Thierry

Bonjour Thierry,
Peut-être te poses-tu trop de questions. Je suppose que ton pré-ampli a une montée progressive de la HT,idem pour les drivers du 845 et le 845 ( avec ces 4 rectifiers) me trompais-je ?
Tu est plus intéressé par la phase extinction  ou tu souhaiterais conserver les filaments allumés quelques dizaine de secondes après que la HT soit tombée à X Volts.
Désolé, ça fait pas avancer le sujet.
Pierrick
Pierrick
Pierrick
Membre Bleu
Membre Bleu

Messages : 319
Date d'inscription : 04/03/2019

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  tboll le Jeu 30 Juil 2020 - 21:58

Bonsoir Pierrick, bonsoir à tous,

Bizarrement, ma haute tension sur les drivers et les étages de sortie monte vraiment très vite 3 à 4 secondes.

Je veux donc déjà gérer rapidement les temporisations au démarrage. J'ai des tubes NOS et je ne veux pas les griller trop vite.

Un copain m'a bricolé un schéma de temporisation et je vais déjà protéger mes tubes.

Si ensuite, Julien nous sort un schéma de course, j'ai de la place dans les coffrets et je mettrais en place.

Tu as raison, je me pose peut être des questions sans fondement. Je vais caler les temps autour de 50 secondes.

Thierry

_________________
- VOT-HP et 416-8B GPA Altec Lansing Alnico
- Pavillon Iwata 1 pouce et compression ALTEC 909-8A
- Tweeter Fostex T925
- CD Marantz 6002
- préamplificateur 76/6SN7 (Sound Practices)
- SE 845 en phase de tests et d'essais
tboll
tboll
Membre Bleu
Membre Bleu

Messages : 422
Date d'inscription : 01/03/2019
Localisation : Chartreuse

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  juju35135 le Jeu 30 Juil 2020 - 22:16

Bonsoir à tous,

Il faut que je clarifie mon code,
Pour le rendre aisément modifiable/personnalisable (bon en programmation il y a toujours plusieurs solutions pour parvenir a un résultat similaire)

.... et également implémenter le contrôle de présence tension sur les filaments (avant et durant la presence de la HT)

Bonne soirée
Julien
juju35135
juju35135
Membre Bleu
Membre Bleu

Messages : 492
Date d'inscription : 01/04/2020
Localisation : Bretagne

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  tboll le Jeu 30 Juil 2020 - 22:37

Bonsoir Julien,

Je sens que tu va nous pondre un super système...

Tu nous raconteras tout ça.

Personnellement, j'ai le temps, j'ai encore quelques trucs à bricoler sur mon système.

Thierry




_________________
- VOT-HP et 416-8B GPA Altec Lansing Alnico
- Pavillon Iwata 1 pouce et compression ALTEC 909-8A
- Tweeter Fostex T925
- CD Marantz 6002
- préamplificateur 76/6SN7 (Sound Practices)
- SE 845 en phase de tests et d'essais
tboll
tboll
Membre Bleu
Membre Bleu

Messages : 422
Date d'inscription : 01/03/2019
Localisation : Chartreuse

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  Julien591 le Ven 31 Juil 2020 - 9:32

Bonjour,

Ce sujet est très intéressant !! J'ai travaillé un peu sur de l'arduino et c'est vrai que c'est bien pratique.

L'étape d’après serait d’ingérer une puce radio pour piloter avec une télécommande la mise sous tension et hors tension et intégrer ce module au préampli et ampli, comme ça, avec un seul bouton, tout s'allume Very Happy Very Happy Very Happy

Julien591
Membre Bleu
Membre Bleu

Messages : 319
Date d'inscription : 02/03/2019

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  Pierrick le Sam 1 Aoû 2020 - 17:08

Bonjour Julien, bonjour thierry, bonjour à tous.

juju35135 a écrit:Il faut que je clarifie mon code,
Pour le rendre aisément modifiable/personnalisable (bon en programmation il y a toujours plusieurs solutions pour parvenir a un résultat similaire)

.... et également implémenter le contrôle de présence tension sur les filaments (avant et durant la presence de la HT)
Tu as raison en programmation tous les chemins mènent à Rome mais beaucoup sont longs.
Pierrick
Pierrick
Pierrick
Membre Bleu
Membre Bleu

Messages : 319
Date d'inscription : 04/03/2019

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  juju35135 le Dim 23 Aoû 2020 - 16:37

Bonjour à tous,

Je vous présente mon projet de commande d'un préamp à tube par arduino :

- Les éléments :
3 alims secteur

- une alim régulée par un petit module stepdown pour l'arduino
- une alim à découpage pour les filaments
- une carte d'alim à valve  EZ80 pour la HT

- Un bouton poussoir lumineux permet de mettre en route/d'arrêter le préamp avec un retour visuel

- Une petite carte 2 relais que l'on trouve partout pilote le chauffage filaments ainsi que la HT

- Un optocoupleur contrôle en permanence la présence tension filament et le cas échéant coupe la HT (le voyant de l'interrupteur se met à clignoter pour en informer l'utilisateur

- le fonctionnement général est le suivant

-Le module reste "en veille" grace à sa petite alimentation dédiée
- Un appui sur le BP provoque l'allumage de sa led, et alimente les filaments.
- La tempo compte 60s et alimente la HT

Pour la séquence d'arrêt
Un appui sur le bouton poussoir, la HT se coupe et le voyant s'eteint
- La tempo compte 30s et coupe le chauffage filaments
- l'appareil reste en veille en attente d'une nouvelle mise en marche

La partie Hardware (j'utilise un arduino nano every, je crois que les adresses different sur d'autres modèles)

[Vous devez être inscrit et connecté pour voir cette image]
la vue peut être tronquée -> cliquez pour zoomer

Ensuite je post mon sketch pour la partie soft

Julien
juju35135
juju35135
Membre Bleu
Membre Bleu

Messages : 492
Date d'inscription : 01/04/2020
Localisation : Bretagne

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  juju35135 le Dim 23 Aoû 2020 - 17:59

....Le soft qui est bien-sûr améliorable/simplifiable/modifiable selon vos goûts et besoins



// -----------------------------------------
// commande et contrôle pour ampli à tube
// juju35135, aucuns droits reservés
// version beta 1.02
// -----------------------------------------


int verif = 3;// verification filament PIN 3
int etatfil=0;// etat du filament
int bouton = 2;// bouton PIN 2
int led = 19;// led sur A5 PIN 19
int etatbouton = 0; // variable etat bouton (appuyé ou non appuyé)
int dernieretatbouton = 0;// variable memoire derniere position du bouton
int etatled = 0;// varibale de la led, soit éteinte soit allumée
int pinR1, pinR2;
int etatR1, etatR2;
int allumage = 1 ; // état allumage
int tempoActive = 0; // État d'activation de la tempo
long prechauffe, postchauffe ;
unsigned long tempoDepart = 0; // Temps à l'activation de la tempo


void setup() {

prechauffe = 60000 ; //durée prechauffage
postchauffe = 30000 ;//durée postchauffage
pinMode(verif, INPUT_PULLUP);
pinR1 = 14; //Relais sur A0 pin 14
pinR2 = 15; //Relais saur A1 pin 15

pinMode(bouton, INPUT_PULLUP);
pinMode(led, OUTPUT);
pinMode(pinR1, OUTPUT); //mode écriture pour relais1
pinMode(pinR2, OUTPUT); //mode écriture pour relais2

digitalWrite(pinR1,HIGH); //forcage relais1 en position ouvert
digitalWrite(pinR2,HIGH); //forcage relais2 en position ouvert
etatR1 = 1; //ecriture variable état relais1
etatR2 = 1; //ecriture variable état relais2

}

void loop() {

etatbouton = digitalRead(bouton); //lecture etat BP

if (etatbouton != dernieretatbouton) {

if (!etatbouton) {//si etatbouton est différent de 1

if (etatled)//et que si etatled est à 1


{
etatled = 0;//nous passons etatled à 0
allumage = 0 ;
etatR1 = 1;
etatR2 = 1;
tempoActive = 1;
tempoDepart = millis();
}
else
{
etatled = 1;//sinon nous le passons à 1
allumage = 1 ;
etatR1 = 0;
etatR2 = 0;
tempoActive = 1;
tempoDepart = millis();


}


}
dernieretatbouton = etatbouton;
}



digitalWrite(led, etatled);

if ( allumage ) {


digitalWrite(pinR1,etatR1); // action sur relais filaments



if ( tempoActive ) {


// Et si il s'est écoulé la tempo de prechauffage
if ( ( millis() - tempoDepart ) >= prechauffe ) {



digitalWrite(pinR2,etatR2); //action sur relais HT

// Et on désactive la temporisation
tempoActive = 0;
}
}}

else {
digitalWrite(pinR2,etatR2); //action sur relais HT

if ( tempoActive ) {


// Et si il s'est écoulé la tempo de postchauffage
if ( ( millis() - tempoDepart ) >= postchauffe ) {



digitalWrite(pinR1,etatR1); //action sur le relais filaments

// Et on désactive la temporisation
tempoActive = 0;
}}

}

delay(200); //interruption de 200ms (anti rebond)

etatfil = digitalRead(verif);


if (etatled != 0){ //si on est en marche

while(etatfil != 0) // disparition du chauffage
{
digitalWrite(pinR2,HIGH); //coupure de la HT
etatfil = digitalRead(verif); // verification du chauffage

//Reset de la tempo
tempoActive = 1 ;
tempoDepart = millis();
allumage = 1 ;

// Clignotement de la LED
digitalWrite(led, LOW);
delay (500);
digitalWrite(led, HIGH);
delay (500);

}}

}
Notez que s'il est en phase d'arrêt ou de préchauffage un nouvel appui sur le BP
le remet dans son état précédent (en conservant bien-sûr la tempo)

Cdt,
Julien
juju35135
juju35135
Membre Bleu
Membre Bleu

Messages : 492
Date d'inscription : 01/04/2020
Localisation : Bretagne

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  tron_ic le Dim 23 Aoû 2020 - 18:18

Bonjour Julien,

Ton projet et ton partage est vraiment très bien et for instructif. Je t'en remercie.

Puisque tu es lancé voici une première suggestion...

1) indiquer la temporisation par un clignotement soit de la Led déjà présente soit d'une seconde Led qui y serait ajoutée. Tu peux aussi imaginer employer une Led bicolore ...

Tu pourrais peut-être envisager d'y intégrer un LCD1, 2 ou x lignes afin de pouvoir afficher différentes indications. Comme tension & courant en différents points du circuit ou tout simplement donner différentes autres indications utiles.

Je dis ça car un arduino aussi petit et micro soit t'il est très puissant ! Wink

Salutations. Tony

_________________
Imagine ce que tu désires, souhaite ce que tu imagines et tu finiras par créer ce que tu veux !
tron_ic
tron_ic
Membre Bleu
Membre Bleu

Messages : 1763
Date d'inscription : 02/03/2019
Localisation : Switzerland

https://officina-tron-audio.blogspot.com/

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  Pierrick le Dim 23 Aoû 2020 - 21:38

Bonsoir Julien,
juju35135 a écrit:....Le soft qui est bien-sûr améliorable/simplifiable/modifiable selon vos goûts et besoins
Je viens de regarder ton code, tu n'as pas hésité à commenter c'est très bien. Je ne connais pas encore le langage Arduino, mais il me semble vraiment pas difficile à lire.

Sinon as-tu  indenté ton code car l'’insertion dans le post la faite disparaitre et là le programme devient moins lisible et maintenable. Ensuite les structures conditionnelles 2 et 3  me chiffonne,

        if (!etatbouton) {//si etatbouton est différent de 1

        if (etatled)//et que si etatled est à 1
Je verrais plutôt
        if (etatbouton != 1   &&  etatled == 1   ) {//si etatbouton est différent de 1 et que si etatled est à 1
Si je me trompe n'hésite pas à me le dire, je n'ai pour le moment aucune expérience de coding en Arduino,  mais je connais d'autres langages de programmation et la conception logicielle.

Je penses à mon retour à la maison, me commander les éléments pour me monter une maquette et tester ton code.

Une dernière chose importante as tu testé le comportement du code lors de la coupure du chauffage filament?

Bonne soirée
Pierrick
Pierrick
Pierrick
Membre Bleu
Membre Bleu

Messages : 319
Date d'inscription : 04/03/2019

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  Pierrick le Dim 23 Aoû 2020 - 21:42

Bonsoir Tony,
tron_ic a écrit:Ton projet et ton partage est vraiment très bien et for instructif. Je t'en remercie.

Puisque tu es lancé voici une première suggestion...

1) indiquer la temporisation par un clignotement soit de la Led déjà présente soit d'une seconde Led qui y serait ajoutée. Tu peux aussi imaginer employer une Led bicolore ...

Tu pourrais peut-être envisager d'y intégrer un LCD1, 2 ou x lignes afin de pouvoir afficher différentes indications. Comme tension & courant en différents points du circuit ou tout simplement donner différentes autres indications utiles.

Je dis ça car un arduino aussi petit et micro soit t'il est très puissant ! Wink
Des bonnes idées mais Julien est pour l'instant sur la version  beta 1.02  de sont programme, attendons  un peu avant de lui proposer des évolutions. Very Happy Very Happy

Salutations
Pierrick
Pierrick
Pierrick
Membre Bleu
Membre Bleu

Messages : 319
Date d'inscription : 04/03/2019

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  juju35135 le Lun 24 Aoû 2020 - 19:58

Bonsoir à tous,

Merci pour votre soutien et suggestions

@Tony, je pense sérieusement rajouter une   led bicolore qui m'informerait de la présence tension (en veille) ainsi que de l'état du système (en temporisation/en marche...)
....Une fois le boîtier fermé je ne verrai plus les leds des relais Wink

je dis ça car un arduino aussi petit et micro soit t'il est très puissant
Oui c'est sur je dois l'utiliser à quelques % de ses capacités et il me reste un paquet d'entrées/sorties dispos Smile

@Pierrick
Sinon as-tu  indenté ton code car l'’insertion dans le post la faite disparaitre
Non j'ai juste fait un copier-coller de l'interface IDE vers mon post....-> Une manip a faire ??

if (etatbouton != 1   &&  etatled == 1   )
Merci du conseil, que je vais appliquer afin de réduire mes conditions "if" en cascade. Ça sera plus élégant et lisible...(Je débute en arduino & ça fait un bail que je n'ai pas fait de code ^^)

Une dernière chose importante as tu testé le comportement du code lors de la coupure du chauffage filament?
Oui bien-sûr je l'ai testé amplement, ça réagit direct, et sans tension le programme reste "prisonnier" de la boucle "while" (ce contrôle est effectif durant le préchauffage que durant le mode de fonctionnement)

Bonne soirée,
Julien
juju35135
juju35135
Membre Bleu
Membre Bleu

Messages : 492
Date d'inscription : 01/04/2020
Localisation : Bretagne

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  Pierrick le Lun 24 Aoû 2020 - 22:24

juju35135 a écrit:@Pierrick
Sinon as-tu  indenté ton code car l'’insertion dans le post la faite disparaitre
Non j'ai juste fait un copier-coller de l'interface IDE vers mon post....
-> Une manip a faire ??
Je viens d'essayer comme toi copier coller entre IDE et le forum, les tabulations disparaissent.
Pour l’instant je ne vois pas comment afficher proprement le code dans le post, peut-être envisager de l'attacher en fichier.
juju35135 a écrit:
Une dernière chose importante as tu testé le comportement du code lors de la coupure du chauffage filament?
Oui bien-sûr je l'ai testé amplement, ça réagit direct, et sans tension le programme reste "prisonnier" de la boucle "while" (ce contrôle est effectif durant le préchauffage que durant le mode de fonctionnement)
c’est une partie délicate, c'est génial si l'arduino coupe la HT à la perte de l'alimentation filament.
Encore bravo Julien.

Bonne soirée
Pierrick
Pierrick
Pierrick
Membre Bleu
Membre Bleu

Messages : 319
Date d'inscription : 04/03/2019

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  Pierrick le Lun 24 Aoû 2020 - 22:30

Bonsoir Julien,

Des  cartes relais pour connecter à l'arduino je pense les avoir trouver, mais pourrais tu STP me/nous communiquer une référence pour les optocoupleurs.
Pierrick
Pierrick
Pierrick
Membre Bleu
Membre Bleu

Messages : 319
Date d'inscription : 04/03/2019

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  juju35135 le Mar 25 Aoû 2020 - 11:36

Bonjour Pierrick,

J'ai acheté les optocoupleurs chez RS. C'est vendu par lot de 10 pour pas cher. Et j'ai coupé un suppot tulipe dip8 en 2 pour le remplacer aisément au cas où....

[Vous devez être inscrit et connecté pour voir cette image]

cosmo K1010 (bien veiller à ne pas dépasser 5ma sinon la diode se étruit, j'ai mis 2 R de 560R côté 6,3V). Le module relais c'est un modèle de ce type

Je viens d'essayer comme toi copier coller entre IDE et le forum, les tabulations disparaissent.
Pour l’instant je ne vois pas comment afficher proprement le code dans le post, peut-être envisager de l'attacher en fichier.
Effectivement c'est embêtant, j'ai vu qu'on peut joindre un fichier texte, pour la prochaine fois je le posterai comme ça (il y aura juste à renommer le .txt en .ino)

Cdt,
Julien
juju35135
juju35135
Membre Bleu
Membre Bleu

Messages : 492
Date d'inscription : 01/04/2020
Localisation : Bretagne

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  stef1777 le Mar 25 Aoû 2020 - 11:55

Bonjour Julien,

Une petite question pour être sur de comprendre. Sur ton schéma, tu a mis que le chauffage est en continu (6.3v DC). Comment réagit le circuit de l'optocoupleur si on est en 6.3v alternatif ?

Pour ton code, met le sur GitHub. Cela simplifiera les choses.

Stéphane

stef1777
Membre Bleu
Membre Bleu

Messages : 836
Date d'inscription : 04/07/2020

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  Pierrick le Mar 25 Aoû 2020 - 18:28

Bonjour Julien,
juju35135 a écrit:J'ai acheté les optocoupleurs chez RS. C'est vendu par lot de 10 pour pas cher. Et j'ai coupé un suppot tulipe dip8 en 2 pour le remplacer aisément au cas où....
Merci pour les liens, sur mes blocs 845, je pense conserver la temporisation actuelle à l'allumage et gérer avec l’Arduino le contrôle des tensions filaments  et l'arrêt temporisé de l'ampli.

Faut que je réfléchisse à l’algorithme que je souhaite développer, mais il devrait y avoir des ressemblance avec ton travail sur la partie contrôle Very Happy.

J'ai 4 tensions de chauffage filaments à contrôler par blocs 3X6.3V et 1X10V.

Ensuite pour l’arrêt de l'ampli la HT tombe à 50V au bout de 60 secondes donc couper le  chauffage des filament après une minute me semble parfait pour des premiers essais.

Bonne soirée
Pierrick
Pierrick
Pierrick
Membre Bleu
Membre Bleu

Messages : 319
Date d'inscription : 04/03/2019

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  juju35135 le Mar 25 Aoû 2020 - 20:03

Bonsoir Stef, & à tous

Sur ton schéma, tu a mis que le chauffage est en continu (6.3v DC). Comment réagit le circuit de l'optocoupleur si on est en 6.3v alternatif ?
...pas testé en alternatif Wink
Je me suis inspiré du schéma de sonelec

[Vous devez être inscrit et connecté pour voir cette image]
...Il y a un redressement de prevu
plus d'info sur cette page

Pour ton code, met le sur GitHub. Cela simplifiera les choses.
Merci, je vais regarder ça

Bonne soirée
Julien
juju35135
juju35135
Membre Bleu
Membre Bleu

Messages : 492
Date d'inscription : 01/04/2020
Localisation : Bretagne

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  Pierrick le Mar 25 Aoû 2020 - 21:18

juju35135 a écrit:Bonsoir Stef, & à tous


...Il y a un redressement de prevu
plus d'info sur cette page

Bonne soirée
Julien

Pour moi le contrôle des l'alimentation du chauffage des filaments a du sens mais je ne vois pas l’intérêt de surveiller la HT.
Si quelqu’un a des explications je suis preneur.
Pierrick
Pierrick
Pierrick
Membre Bleu
Membre Bleu

Messages : 319
Date d'inscription : 04/03/2019

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  stef1777 le Mar 25 Aoû 2020 - 21:51

Pierrick a écrit:Pour moi  le contrôle des l'alimentation du chauffage des filaments a du sens mais je ne vois pas l’intérêt de surveiller la HT.
Si quelqu’un a des explications je suis preneur.
J'y vois l'interêt de savoir si la valve ne marche plus avec une led en façade.

stef1777
Membre Bleu
Membre Bleu

Messages : 836
Date d'inscription : 04/07/2020

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  juju35135 le Mar 25 Aoû 2020 - 21:53

@Stef, on a posté en même temps Wink
Oui ça peut être utile, par contre je n'aime pas trop comment c'est fait sur le schéma sonelec (en direct), je rajouterais un optocoupleur pour protéger le microcontrôleur...

Mais à part ce cas, je ne vois pas trop l'intérêt de surveiller la HT...
De même que la fonction "soft start" avec les 2 relais... dans mon cas la valve joue ce rôle .
(autant se limiter à la commande et aux sécurités; filaments, tension de bias, le cas échéant...)

De plus complexifier le système augmente aussi le risque de panne

A mon sens si l'on veut vraiment connaître la valeur de la HT, il est plus simple de mettre un petit voltmetre analogique en façade...

Julien .
juju35135
juju35135
Membre Bleu
Membre Bleu

Messages : 492
Date d'inscription : 01/04/2020
Localisation : Bretagne

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  Jef le Jeu 27 Aoû 2020 - 8:53

Bonjour Julien

Félicitation pour ton préampli sur l'autre fil !
Je ne retrouve plus la version de Nano que tu as utilisé... j'ai pourtant lu qq part que c'était pas la version de base !

Je dis cela car en utilisant Fritzing avec la version de base Arduino Nano et tous les opto... etc etc autour tu pourrais obtenir très simplement un circuit imprimé pour une intégration facile et reproductible pour tes autres appareils

Jef
Jef
Jef
Membre Bleu
Membre Bleu

Messages : 374
Date d'inscription : 01/03/2019

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  juju35135 le Jeu 27 Aoû 2020 - 12:07

Bonjour Jef,

Merci pour tes félicitations Pour l'arduino c'est celui-ci

Apparemment il a le même brochage que le nano "standard" le processeur n'est pas le même et y'a un peu plus de mémoire je crois...

Merci pour "Fritzing" je regarderai ça, utile pour faire un circuit plus "pro" et plus compact Smile

Bon après-midi
Julien
juju35135
juju35135
Membre Bleu
Membre Bleu

Messages : 492
Date d'inscription : 01/04/2020
Localisation : Bretagne

Revenir en haut Aller en bas

Arduino & Co dans le moteur ? - Page 3 Empty Re: Arduino & Co dans le moteur ?

Message  Jef le Sam 29 Aoû 2020 - 9:18

Bonjour

La différence essentielle se situe dans la possibilité du wifi intégré dans la version "every"

Jef
Jef
Jef
Membre Bleu
Membre Bleu

Messages : 374
Date d'inscription : 01/03/2019

Revenir en haut Aller en bas

Page 3 sur 4 Précédent  1, 2, 3, 4  Suivant

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum